[Samba] Problem with script logon

Robert Dahlem Robert.Dahlem at gmx.net
Mon Feb 11 23:28:02 GMT 2002


On Fri,  8 Feb 2002 07:52:09 -0800 (PST), Cleiton L. Siqueira wrote:

>I've had a problem with my Samba Server. I've installed it in my 
>FreeBSD 4.2 box. The script logon is running in the Windows 98, but 
>it isn't mapping the drive. My script is test.bat and is written the 
>following line into the script:


>When the script runs, it returns me that the share doesn't exist or 
>is written wrong. Therefore, If I run the same command NET USE F: 
>\\SERVER\TEST in a DOS prompt, it gets to map the drive.
>It's weird, because if it gets to map after logon why doesn't it get 
>to map when the script logon is running?

It might be the Client Services are not fully up when the logon script 
is running.

As a first attempt: Try inserting a PAUSE command before NET USE. Let 
the script run into the PAUSE command, wait a minute, then hit ENTER. 
If it works now, you know you will have to loop until services are 
fully up.


Robert.Dahlem at gmx.net

Sent using PMMail (http://www.pmmail2000.com) - fast, decent, email
software; far better than Outlook. Try it sometime.

More information about the samba mailing list