[Samba] Prob. with Printer Drivers W2k Samba 2.2.3

Martin Thomas mthomas at rhrk.uni-kl.de
Wed Feb 6 13:54:04 GMT 2002


since Samba 2.2.3 is working now with Jeremy's patch
- thanks again - the next step here is to migrate to
the new printer-handling (rpc, spools). I try to explain 
the steps I did so far: 
 (sorry, text is a little long, but wanted to give a 
 reproduceable example)

- created a print$ which points to a directory 
  owned by root/group smbadm, set write list = @smbadm
- made me member of group smbadm
- tested to copy some files to \\server1\print$ from
  a client - works - so access rights should be right
- created a printable share [djtest] in smb.conf
- downloaded the NT4 and Windows 2000 printer
  drivers for a HP Deskjet 1120C from the HP-Site
  and unpacked both
- browsed to the Printer Wizard of server1, and
  tried to show the printer properties -> results
  in a message like "can't show properties, driver
  is not installed - do you want to install?" -
  I pressed 'no' like statet somewhere in the documentation
  I found. Client shows the 'reduced' properties
- selected 'extended settings', button 'new driver',
  Wizard shows up, selected 'have disk', browsed
  to the local directory where I unpacked the
  Windows NT drivers. Client wants the W2K Server CD,
  irgnored it (I don't have one) and browsed again to 
  the NT driver-dir. and select the dj1120c.inf-File, warning about 
  unsigned driver, pressed yes, upload of drivers starts
- * Problem 1 * :  one of the files in the driver package is
  called HPW5ecp.sy_ but during the upload process
  the message 'File can not be copied appeared',
  in the inf-File the destination for this file is 
  different from the the others, what do this numbers
        from DJ1120C.INF: 
- set ECPFile=11 as a temporary workaround to test
  the upload, and tried a again, no error-message,
  all Files are now on the server.
- * Problem 2 *: did "rpcclient server1 -U me" and
  a "enumdrivers" at the command prompt, but got no output,
  seems that there is no driver installed.
- ok, since I do not need the NT Driver, I tried to
  add the W2K-Driver - selected properties, sharing,
  additional drivers, marked Windows 2000, same
  procedure as described above, again "Problem 1"
  since it seems that W2K used the local DJ1120C.inf
  File already stored somewhere in the \winnt path I 
  did not change the inf-File.
  selected 'cancel' - selected "yes" at  'skip this file 
  and continue' message, rest of the driver files where
  copied to the server.
- again did rpcclient->enumdrivers and got no output,
  enumprinters works, and shows:
        description:[radagast\\radagast\djtest,HP DeskJet 1120C Printer,]
- * Problem 3 *, again selected properties in the APW,
  again message no driver, and the 'additional drivers'-list
  does not show a mark near Windows 2000 - it seems
  the uploadad driver has no entry in some of the internal
  samba-database-tables - what am I doing wrong?

Hard/Software: Server: Debian, Linux-Kernel 2.2.18, Samba 2.2.3
 with 'overwrite path from CVS', configured with no special options,
 installed in /usr/local/samba..., Clients: Win2000SP2, german

Can someone help me please? - thanks.


More information about the samba mailing list