[Samba] Samba and Apple's X Server

Christopher Rank chris at aquanetworks.net
Sat Feb 2 11:50:04 GMT 2002


First off great work guys...I am really excited about all of the changes 
and improvements made over the last few years.  I have been running 
2.0.7 as a PDC for almost 18 months now and it has been great.  I have a 
new problem that I searched the lists for and have now come to you 
directly because it is nowhere to be found in any discussions that 
anyone has had.  I think that my problem is unique.  Yea!  I am sure 
that is exciting.


Here is the scoop.  I have 2.2.1a build on a current build of Apple's 
MacOS X Server ( http://www.apple.com/macosx/server ) Ok, this system 
comes with a binary preinstalled and working with encryption.  I have it 
working and have now figured out how to make the sucker into a PDC just 
like my 2.0.7 box.  Here is the difference.  My 2.0.7 box has a standard 
build of SaMBa with a smbpasswd file and everything.  The difference 
here is that Apple has built the authentication into the app and a small 
config gui called radmin.  Now I have figured out how to get the stupid 
gui to overwrite my conf file, but what I haven't been able to get 
around is this, the widows machine gives me a pretty strange error when 
I try and add an account:

The account you are attempting to use is a machine account.  Try using 
your Global Administrator account or and account with proper privileges.

Huh?  I am using the root account.  When I type in the wrong password I 
get a proper bad password error.  So clearly the win2k machine is 
receiving some sort of response from the server, but the server is not 
allowing the machine account to be created because it is convinced that 
it is an unprivileged user and tells the 2k machine that the root 
account does not have enough privileges.  Talk about pissing you off!  
So then I tried to create an smbpasswd file, added the root account 
properly and got the same error.  I am a pretty seasoned samba veteran, 
but this one has me stumped.  Here is what I would love to see.

If someone has a fix for this, please send it to me so that I can work 
around this and have my nice shiny new PDC working.

If this is a new bug that Apple has introduced because of some kind of 
proprietary whackness, let me know that to so that the samba folks can 
contact Apple and have them fix their code.  Also if Apple doesn't 
comply with the samba team then we can put pressure on them from the 
community to comply because of their use of an open source project.  
Apple has contributed greatly to the community and I know that they 
should be responsive.  One other thing though, I couldn't find the 
source code that they used to create the new binaries.  I know that they 
released some, but I can no longer find it on the Darwin site.  So any 
comments or fixes for this would be greatly appreciated. Thanks!

More information about the samba mailing list