[Samba] samba stopped starting

Joel Hammer Joel at HammersHome.com
Fri Feb 1 04:30:05 GMT 2002

You didn't mention looking into /usr/local/samba/var/log.smbd.
As a last resort, you might try:
strace smbd -D 2>junk
and read what is in junk.
BTW, you aren't trying to start samba as a regular user, are you?

On Thu, Jan 31, 2002 at 10:53:09PM -0600, Robert Campbell wrote:
> yes the .pid files are being created cause I removed them and then ran
> smbd -D and nmbd -D again and they were recreated.  I would read the files
> but the pid numbers in the files didn't exist, neither were running.
> and it is putting absolutely nothing in the /var/log/message file.
> I cleared my entire message file and tried to start samba again to see if
> anything would appear in the log file.
> is there something else in the file system that samba needs that could have
> been corrupt?
> Rob
> P.S. thanx for the speedy response on my strange and tricky problem.
> ----- Original Message -----
> From: "Joel Hammer" <Joel at HammersHome.com>
> To: "Robert Campbell" <rob103 at hickorytech.net>; <samba at lists.samba.org>
> Sent: Thursday, January 31, 2002 9:13 PM
> Subject: Re: [Samba] samba stopped starting
> > Are you sure the pid files are being created or are they the old files?
> > Have you looked in the log files for smbd and nmbd to see what happened?
> > Anything in /var/log/messages?
> > I do not think reinstalling the OS is necessary to solve this problem.
> >
> > Joel
> >
> > On Thu, Jan 31, 2002 at 09:00:32PM -0600, Robert Campbell wrote:
> > > I did a port scan with Nessus and now samba has stopped working.
> > >I run it with smbd -D and nmbd -D  and they both seem to start without
> any
> > >errors and the .pid files are created.  then I do a ps ax and neither of
> > >the programs are running but the .pids are still in place.  I had this
> > >problem once before... I tried upgrading samba before and everything
> > >but the only way I was able to fix it was to re-install the entire OS.
> > > I am running SlackWare8.0 now but the first time it happened was on
> > >SlackWare7.1 > any ideas how to fix this please?
> >

More information about the samba mailing list