[Samba] error message in smbd.log file: bind failed on port 139 socket_addr =

phil brogan philbrog at ptd.net
Mon Dec 30 07:33:01 GMT 2002

 > > tcp is a transport protocol. It isn't a daemon. You have not
 > > understood the
 > > output.
 > > Post the output of netstat -anp | grep 139.
 > > Is xinetd or inetd or smbd listening to this port?
 > I tried netstat -anp | grep 139 and I see that it is indeed xinetd
 > which
 > is listening on that port.  How do I resolve this conflict?

I removed xinetd's files for netbios-ns and netbios-ssn, started nmbd 
and smbd and they are running.  Oddly enough, I created the netbios-ns 
and netbios-ssn files for xinetd as per instructions from Jerry Carter's 
book "Teach Yourself Samba in 24 Hours".  Why would that book tell me to 
do something that breaks Samba?


I did an smbstatus, got error message "Failed to open byte range locking 
database", fixed it by using command "smbclient -L localhost".

I went to a Win98 machine, did a "net view \\linux-computer-name" and 
received an Error 53 message from Windows "The computer name in the 
network path cannot be located."  Yet I can ping linux-computer-name by 
name from the Win98 box.

Any help would be appreciated, thank you.

More information about the samba mailing list