[Samba] Weird Samba Browsing Problem

afleming at fhsu.edu afleming at fhsu.edu
Wed Aug 28 09:26:00 GMT 2002

If anyone can help me with this problem I'd appreciate it.  I've searched
the archive and not found anything that looks like the same problem.

I have a FreeBSD4.6 machine running Samba 2.2.5 our of the FreeBSD ports
collection.  This machine is acting as a PDC for a domain called labs.  The
machine is configured as the Domain Master browser and Local Master
browser.  We also have some different NT domain on our network and one of
them is running a WINS server, so we are just using that.  The Samba
machine and the clients are all registering in the WINS database.  The
samba machine is on a different subnet that there are no other clients on.

When I go to look at the browse list on any of the machines in the LABS
domain all I see is the Samba server I don't even see the workstations I
check from.  The following is from the log.nmbd file.  (I know I should
take out the IP Addresses, but I'm frustrated enough don't really care.)

[2002/08/20 00:57:15, 2] nmbd/nmbd_browsesync.c:sync_with_lmb(69)
  Initiating sync with local master browser NURS-STH122-07<0x20> at IP for workgroup LABS
[2002/08/20 00:57:15, 2] nmbd/nmbd_synclists.c:sync_browse_lists(168)
  Initiating browse sync for LABS to NURS-STH122-07(
[2002/08/20 00:57:15, 2] nmbd/nmbd_synclists.c:complete_sync(283)
  sync with NURS-STH122-07( for workgroup LABS completed (0

This makes no since to me.  In this case NURS-STH122-07 is the local master
browser for the labs group on the subnet.  The samba server
is trying to sync with it, but it is getting 0 records.  Shouldn't I at
least be getting one record for the workstation the Samba server is syncing

This all worked fine until this summer.  I did have Samba running on a
FreeBSD 4.3 machine with an older version of Samba.  I got a new Dell
server this summer to replace it and set it up with FreeBSD4.6 and the
Samba 2.2.5 and started having this problem.  I copied over the files form
the /etc/local/private, I can even unjoin the 2000 workstations from the
domain and then rejoin them to the Domain with no problems, so I'm at a
loss as what is wrong.  I can provide any configs and logs anyone wants to
see I just didn't want to include all of that in the initial e-mail.  I've
been banging my head against the wall for over a month off and on about
this.  WINS and log-on still work, so it is not like things are not
working, but it is annoying and I have users keep bugging me about it.
I've tried so many different things that I don't know if I remember
everything I've tried.

Thanks for any suggestions


Andrew Fleming
Fort Hays State University
Computing Center
afleming at fhsu.edu

More information about the samba mailing list