[Samba] Windows shares, smbclient and missing files

Sauli Raivio sauli.raivio at rlsystems.fi
Sun Aug 11 12:47:01 GMT 2002


There seems to be a problem with smbclient and windows shares. Command  
'smbclient //server/share -U uname%passwd -c "pro,rec,mget directory", 
makes the direcory structure but sometimes there are files missing. 
Things get even worse if transfer is started several times  
simultaneously (into diffrent directories). I've been testing 3-4 
transfers at the same time and every time at least one directory is 
missing files. Samba-> samba, win->samba and win->win works ok. I've 
tried RedHat 7.3, SuSE 8.0, FreeBSD 4.4, win200sp2, nt40ws sp6 and 
windows nt small business server sp3.  I even tried to compile samba 
2.2.5 on RH73 with no luck. The windows share has about 1.7GB of 
miscellanous files. This happens in two networks so I guess it's not a 
hardware problem. NICs are mostly 3COM.

Google didn't give any help. Is this somekind of configuration error or 

Sauli Raivio
sauli.raivio at rlsystems.fi

More information about the samba mailing list