[Samba] RedHat 7.3 smbmount

Urban Widmark urban at teststation.com
Wed Aug 7 08:05:01 GMT 2002

On Tue, 6 Aug 2002, John Hines wrote:

> Hello,
> I have a RedHat 7.3 workstation and have created a samba mount to my
> samba server.  Everything seems to be working ok, but when I reboot my
> RH workstation the mount is not reestablished.  I believe the problem is
> that when I reboot the machine the samba share is not unmounted.  After
> rebooting the machine when I run smbstatus on the samba server it
> indicates the mount is still active.

When you reboot the connection is dropped and the server should see that
as an umount. At least after a while ...

> I when I run smbumount before I reboot I don't run into the problem.  
> Is there any way to fix this problem without having to manually unmout
> the shares every time i reboot or power down my Linux box?

umount -a -t smbfs

/etc/init.d/netfs should be run on shutdown and should unmount for you. It
includes this line, and if you had any smbfs mounts it should find them.

[ -n "$SMBMTAB" ] && action $"Unmounting SMB filesystems: " umount -a -t smbfs

If you don't get that printout on shutdown, try adding the umount command
on a line of it's own.


More information about the samba mailing list