[Samba] RE: I have a few different problems with samba 2.2.5 PLEASE HELP

Jason Corekin crazy_j_c at hotmail.com
Fri Aug 2 23:08:03 GMT 2002

Here's and update.  I have guaranteed that the use I am using to try to do this have FULL permissions by placing him in both the printer admin and samba admin lists.  He is also a part of the root group on the box.  When I log in directly with rpcclient I am told that I am logging "in as admin user (root privileges)".  Bur for whatever reason when I run the command 'addprinter "HPColor" "HPColor2" "HP Color Inkjet CP1700" "Samba Printer Port"' I get the message "002c status: WERR_ACCESS_DENIED".  What is up with this?

Jason Corekin
  ----- Original Message ----- 
  From: Jason Corekin 
  To: Samba List 
  Sent: Friday, August 02, 2002 3:03 AM
  Subject: [Samba] I have a few different problems with samba 2.2.5 PLEASE HELP

  I am running samba 2.2.5 on a Redhat Linux 7.3 box in a very large Windows NT domain, and I am running into a few different issues that make no sense to me.

  1) For some reason my local clients can only get to the server by using it's fully qualified domain name.  If you use the short name you receive a message about not being permitted to connect from the current workstation ( or something similar, I can't remember). The two strange things are that I can use the short name for all other services and we have other boxes running samba 2.2.2 on Tru64 UNIX and the short names work just fine to connect to them, and I largely copied the configuration I am using off of the primary server. 

  2) The purpose of this machine is to be a print server for an HP Color Inkjet CP1700.  This is a fully supported printer and I have it setup correctly on Linux.  I am using LPRng as my printing system and can even print from my Windows Clients when I use locally supplied drivers.  However since this is supposed to be a easy to use, public printer I do not want the users having to manually locate the driver files.  So I am trying to configure the sever to store the files.  I have tried to follow the HOWTO and I get all of the messages.  But no matter what I do, when I hand it the driver files Windows always installs them locally and does not upload them to the server.  I have already setup the print$ and made sure that I have permission to write to it via the printadmin group.  Since automated upload did not work for me, I have been trying to make use of imprints.  I have been able to successfully create a package, but when I go to use install_print_driver.pl I keep finding that the server lists off no valid ports, not even Samba Printer Port.  I even made a script to run with enumports command that echo's "Samba Printer Port", but still have had no luck. What am I doing wrong?

  3) Even though my map file is correctly setup and my authentication appears correct as well (I can connect to the box and it map me to the correct UNIX user such that I see my UNIX home directory) I keep getting errors about not being able to open passdb database.  I am not using smbpasswd nor windbind, just an existing password server that all of the other servers use as well.

  Could any of these be related?
  Does anyone have any idea what could cause this?
  If you need more info I can send it to you, but seeing as the message is already long and it is late for me, this is all I can offer right now.

  Thank you in advance for any time you might spend on this.

  Jason Corekin
  Hewlett-Packard Intern
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list