[Samba] encrypted passwords?

Darin DeCounter ddecounter at reviewjournal.com
Mon Apr 1 13:50:03 GMT 2002

I found a pretty old posting (for Linux), November 1999, that referenced
the exact same error msg I'm getting.  They suggested setting "encrypt
passwords = no" and making a change to the registry settings on our
clients.  Does anyone know if this is our only recourse, provided we're
wanting to authenticate the way I've described below??  Any help would be
most appreciated.

We're using an RS6000 w/ Win95 clients and only wanting to authenticate
through our NT PDC.  We don't want to use the matching username/pswd at the
AIX level...if their network login passes the PDC and provided they belong
to the proper workgroup, they should be able to map (is it even possible to
do this?).  When I run through the diagnostic steps and issue "smbclient
//testsrv/ads" (I didn't actually use quotes in the command), I get the

added interface ip= bcast= nmask=
Anonymous login successful
Domain=[ATEX] OS=[Unix] Server=[Samba 2.2.2]
tree connect failed: ERRSRV - ERRbadpw (Bad password - name/password pair
in a Tree Connect or Session Setup are invalid.)

Our smb.conf is as follows:

   workgroup = ATEX
   dns proxy = yes
   security = domain
   encrypt passwords = yes
   password server = *
   netbios name = testsrv

      read only = no
      path = /ads  

Does anyone have an idea what we're doing wrong?  Thanks for any assistance.
Darin DeCounter

Atex Assistant System Administrator
Las Vegas Review-Journal
ddecounter at reviewjournal.com

More information about the samba mailing list