[Samba] encrypted passwords?

Brian Whitehead bwhitehd at earthlink.net
Tue Apr 2 09:42:03 GMT 2002

What patches/service packs are installed on the Win95 machines?  Which
version of Win95? (original, OSR1, OSR3)

The plain text passwords used to be a problem, but that was fixed.  I don't
recall which Win95 patch fixed it though.  I do know that there are about 12
patches for Win95, some are not publicly released.  I wrote a roll-up
program for a university I used to work at.  Unfortunately, I can not share
it because it contains some of those non-public patches from Microshaft.
Anyway, check the following site to give you an idea of what patches you
should have installed on the Win95 clients.

----- Original Message -----
From: "Darin DeCounter" <ddecounter at reviewjournal.com>
To: <samba at lists.samba.org>
Sent: Monday, April 01, 2002 3:48 PM
Subject: [Samba] encrypted passwords?

> I found a pretty old posting (for Linux), November 1999, that referenced
> the exact same error msg I'm getting.  They suggested setting "encrypt
> passwords = no" and making a change to the registry settings on our
> clients.  Does anyone know if this is our only recourse, provided we're
> wanting to authenticate the way I've described below??  Any help would be
> most appreciated.
> We're using an RS6000 w/ Win95 clients and only wanting to authenticate
> through our NT PDC.  We don't want to use the matching username/pswd at
> AIX level...if their network login passes the PDC and provided they belong
> to the proper workgroup, they should be able to map (is it even possible
> do this?).  When I run through the diagnostic steps and issue "smbclient
> //testsrv/ads" (I didn't actually use quotes in the command), I get the
> following:
> added interface ip= bcast=
> Password:
> Anonymous login successful
> Domain=[ATEX] OS=[Unix] Server=[Samba 2.2.2]
> tree connect failed: ERRSRV - ERRbadpw (Bad password - name/password pair
> in a Tree Connect or Session Setup are invalid.)
> testsrv{root}#
> Our smb.conf is as follows:
> [global]
>    workgroup = ATEX
>    dns proxy = yes
>    security = domain
>    encrypt passwords = yes
>    password server = *
>    netbios name = testsrv
>    [ads]
>       read only = no
>       path = /ads
> Does anyone have an idea what we're doing wrong?  Thanks for any
> Darin DeCounter
> Atex Assistant System Administrator
> Las Vegas Review-Journal
> 702-387-5230
> ddecounter at reviewjournal.com
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list