Winbind working, but...

Rogelio J. Baucells rogelio at
Tue Oct 23 15:45:02 GMT 2001


I have had winbind working without any problem for several weeks, but I
have a couple of problems with mail delivery and an error when a user
logs in the linux box using ssh, telnet or a simple "su -l

I am running it in a RedHat linux 7.1 and 7.0. I modified the
nsswitch.conf and /etc/system-auth files to make it work. I have tried
with samba-2.2.2 and CVS SAMBA_2_2

Every time a user logs into the box using telnet ..., I receive the
following error:

Last login: Tue Oct 23 16:41:59 2001 from
[: too many arguments
[DOMAIN\username at linuxbox username]$

I modified the PROMPT_COMMAND line in /etc/bashrc from

PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'


PROMPT_COMMAND='echo -ne "\033]0;";echo -n "${USER}@${HOSTNAME}:
${PWD}"; echo -ne "\007"'

to fix a problem with the prompt.

I have look everywhere for the error "[: too many arguments" without any

The other problem I am having is with the mail, I have tried everything
I can imagine to send an email to a user with an account of type
"DOMAIN\username", and to receive this email using pine, mail or even

If I use a pop3 client to get the mail from the box, I can log in, but
it did not find any mail sent to me. I copied a mail file from another
user to my account and chown it appropiatly.
(cp /var/spool/mail/user1 /var/spool/mail/DOMAIN\\username). I have
tried with only one "\" and without it.

I Changed the "winbind separator" to "+" and tried send a mail to
DOMAIN+username, and it continue saying "DOMAIN+username... User

Is anybody having the same problems?

Is anybody receiving/sending mail from/to a user in the samba box with
an account controlled by winbind?


Rogelio J. Baucells

More information about the samba mailing list