no response received to oplock break request

Bill Moran wmoran at
Fri Oct 12 06:02:23 GMT 2001

Enno Pemöller wrote:
> Hi All,
> My problem started with new server hardware and software update, also I
> changed my network from 10 to 100Mb (New Cable and switches)
> I have a problem with oplocks. I run Samba 2.0.10 (also tried 2.2.1a) on
> Suse 7.1 Kernel 2.4. Several times a day I have an oplock error like this:
> (request_oplock_break: no response received to oplock break request to pid
> 5312 on port 32857 for dev = 803, inode = 246701)
> Sometimes it is possible for me to locate a client that hangs an give no
> answer to the oplock request, and ok, WIN98ME Clients will hang sometimes,
> but on one share I run a dos database Software (Cobol), and when there is an
> oplock problem all clients hang and most time I have to restart samba.
> Is there any one who knows what I can do?

The Windows 9X line seems to have a lot of trouble with oplocks. You may want
to turn oplocks off altogether.
YOu can also try the "veto oplock files" parameter in smb.conf to turn off
oplocks only for the files that seem to be causing problems.  Personally, I
think this is more work than it's worth, since any files that would be causing
trouble with oplocks will be the same files that would benefit from oplocking,
so why go to the trouble and time of identifying them when you can just turn
it off altogether.
My understanding is that this is a windows bug, Windows 9x has buggy oplock
code, while NT/2000 works OK with oplocks.  Anyone more in the know on this,
feel free to correct me if I'm wrong.


"Where's the robot to pat you on the back?"

More information about the samba mailing list