Who else can reproduce this problem?

Oliver Six o.six at cahos.net
Mon Nov 26 10:12:18 GMT 2001

<junkmail at tomcat.umsl.edu> wrote on 26.11.2001 18:14:26:

>I truely believe I've stumbled across a bug deleting directories.  The
>bug is either with Windows 2000 or with Samba 2.2.1a and 2.2.2.  I'd
>tend to think it was a Windows bug except that the problem does not
>occur against earlier versions of Samba.
>I've duplicated this problem deleting directories to Samba versions
>2.2.2 and 2.2.1a in various configurations running on several
>different Sparc/Solaris platforms and today I built Samba 2.2.2 on a
>I386/Redhat 7 platform and can still produce the same problem under
>this very different architecture.  This problem is four for four from
>the four Windows 2000 machines I've tried.
>I'm running Windows 2000 SP2 and all the other various updates, I
>believe all four Windows 2000 systems I've tested with are at SP2 so I
>don't know if it happens with Windows 2000 SP1, it does NOT happen
>using a Windows 98 SE system nor does the problem happen from Windows
>2000 SP2 to Samba servers of version 2.0.9.
>Some of you PLEASE try to reproduce this and post your results.  The
>problem is as such. I've tried to be as detailed as possible.  Please
>try to follow my instructions exactly.
>Using Windows Explorer, Explore a drive mapped to Samba share or just
>explore the share itself, it doesn't really need to be mapped.  The
>key is to be exploring it it in Windows Explorer.
>Ok, so you're in Windows Explorer exploring a Samba share or drive
>mapped to a Samba share.  The problem is in deleting a folder.  If
>there isn't a folder you can delete, make one.
>On the left pane of Windows Explorer you've got all the little yellow
>folders and plus signs next to them so you can expand them, and then
>the contents of the current folder are displayed in the right pane.
>IN THE LEFT PANE, left click once on the folder you want to delete.
>Its name will be highlighted and THE LITTLE YELLOW FOLDER ICON JUST TO
>THE LEFT OF ITS NAME WILL BE OPEN and the contents of the folder are
>displayed in the right pane.
>Press the delete key on the keyboard or pointing at the folder name in
>the left pane press the right mouse button and select delete from the
>drop down menu.
>Everything (if anything) in the folder will be deleted but not the
>folder itself.  You'll get "Error Deleting File or Folder, Cannot
>remove folder xxxx: Access is denied, the souce file may be in use." 
>Click OK so the error goes away, then try deleting the folder a second
>time and it will then delete.
>I've tried everything I can think of to narrow down or find a reason
>for this, both on the Samba side and the Windows 2000 side.  All to no
>So, who else can reproduce this?
>Tom Schaefer
>Unix Administrator, University of Missouri St. Louis
>To unsubscribe from this list go to the following URL and read the
>instructions:  http://lists.samba.org/mailman/listinfo/samba

Hi Tom,

I can reproduce this. But I think "it's not a bug it's a feature". Because 
the folder you want to delete is open (in the right pane), you cannot 
delete it. Try to rightclick an _unselected_ folder and delete it - this 
will work, even in the left pane of explorer. It's like formating a floppy..

Ciao Oliver
Good programming is 40% experience, 30% skill, 20% RTFM, 10% caffeine, and 
5% attention to detail. 

Oliver Six, CEO
CAHOS GmbH, Cimbernstr. 51, Germany 81377 Muenchen
Phone +49 89 71 01 93 40,  Fax +49 89 71 01 93 41

More information about the samba mailing list