security = domain

Charles Crawford ccrawford at
Tue Feb 13 03:02:54 GMT 2001

OK, call me brain dead...

I solved this problem which really was not a problem with Samba at all.

The problem was my /etc/hosts file. I had set the file up with the correct
IP addresses originally, but a few months back, before switching to
security=domain, I had changed a 
lot of the client machine's ip addresses. I thought that since the NT
machine was functioning as the DC and the WINS server, that the NT box would
handle the ip resolution. It did, but not fast enough. When the network had
very little traffic, it would work fine, but when the load kicked in, it
would time out.

I've since corrected the /etc/hosts file and have not had any problems at
all. In fact, it seems to work faster than it ever did. I have added every
device on our network that is assigned a local ip address (192.168.1.x) to
the file. The printers respond quickly and the client machines work great as

I've just about gone bald while working on this problem (just joking there)
when I should have checked this file first. My mistake was relying on the NT
machine for ip resolution. It works, but only for very light network

I worked ages trying to figure out where the bottleneck was. I checked my
brand new, top of the line, Cisco switches, but they were working without
any problems. No packet loss at all, or if there were some losses, it was
VERY minimal.

It took me a while to figure out all of the nuances of security=domain, but
once I got the hang of it, I actually can make good use of it. Especially
since I have to have an NT box as the DC due to the fact that I've got a few
NT workstations on the network, and also our mail server is Exchange. I'm
working on that one though, I hear that Lotus and Suse are working together
now... I'm going to try to get our groupware platform over to that
combination very soon.

Anyway, let me know if I can help you with your security=domain problem.
Feed me some specifics and I'll give it a shot. 

I do make use of the readonly and writable options under the share section.
I have a combination of shares that for some groups of users are read only,
others are writable, and still other users have no access. One thing that I
found I needed to do was make use of the default groups and permissions for
each share. When multiple users write to the same share, the user:group
permissions can get really hosed if you don't define the defaults in the
share section.

Oh well, hope this helps.


-----Original Message-----
From: John Doe [mailto:johnny_5five at]
Sent: Monday, February 12, 2001 8:48 PM
To: Charles Crawford
Subject: security = domain

hey, i am having problems with security = domain also, but i was curious as
to wether or not you may have the option "write ok = yes" or "read only =
no" or "writeable = yes" in either the global section or the share section.
This would allow for (i think) everyone to be able to write to this share.
if you have one of these in the global, try to put a "read only = yes" in
the share.  

Get your small business started at Lycos Small Business at

More information about the samba mailing list