Error accessing NT share

Urban Widmark urban at
Thu Sep 28 17:37:44 GMT 2000

On Thu, 28 Sep 2000 Gearoid_King at wrote:

> I created a share on my NT box, providing read access to everyone.
> I've mounted the NT share on my RedHat Linux box at mount point /mnt/test.
> When I try to view the contents of this directory I keep getting the
> following error:    ls: .: Input/output error

Immediately or after a while?
Do you get any messages in the kernel log? (dmesg or /var/log/messages)
Which samba version?
Which linux version?
What command do you use to mount it?
Any strange output from the mount command?

There are a number of problems with smbfs/smbmount that all give an
Input/Output error.

> I've tried creating the mount in linuxconf but it doesn't show up in the GUI
> interface. I've also tried smbmount to no avail. It does however show up in
> the listing when I run mount. 

Stay away from linuxconf :)

Does it show up if you do 'cat /proc/mounts' ?

'mount' shows what is written in /etc/mtab, which is not necessarily the
same as what is actually mounted. Someone has reported problems where
smbmount appears to have updated /etc/mtab and then failed.


More information about the samba mailing list