Samba V2.07 Not working for me (Please Help)

Steven Johnson sbjohnson at
Tue Nov 21 23:10:15 GMT 2000

Urban Widmark wrote:

I have worked around it, it turns out to be a Linux kernel problem of some

I am using Mandrake 7.2 and it has several different kernels, it installed the 
"secure" variant this caused the problem. I changed the kernel back to standard 
and the problem went away. It was a locking problem in sysv_shm_open() the
error given was
"Can't create or use IPC area. File Exists (667)"

I couldn't work out why.

> On Tue, 21 Nov 2000, Steven Johnson wrote:
> > My Samba server becomes unavailable if I mount a share using SMBFS. The
> > following is what I see at the client.
> A possible DoS vs samba using smbfs ... (sort of ironic). Does the mounted
> share work? Are there any messages in the kernel log (dmesg) on the client
> side?
> > [root at steven /etc]# mount /shares/osiris/public/
> What hides behind this command? (what is in your /etc/fstab?)

It is :
// /shares/osiris/public smbfs
user,username=steven,password=password,fmask=777,dmask=0 0 0

It also fails if I open the share from Windows.

> > [root at steven /etc]# smbclient -L osiris
> > added interface ip= bcast= nmask=
> > Password:
> > Domain=[NEURIZON] OS=[Unix] Server=[Samba 2.0.7]
> Interesting, it doesn't fail at once?
> Also, unlike the first 'smbclient -L' it now knows about the workgroup.

Yes. I noticed that as well.

> > [root at steven /etc]# smbclient -L osiris
> > added interface ip= bcast= nmask=
> > session request to OSIRIS failed (code 0)
> > session request to *SMBSERVER failed (code 0)
> And then it fails (code 0 sounds suspiciously like the error code for
> success ...).
> Time between these commands?
> Does it make any difference if some other machine is/becomes "master"?

Nope, same effect. The commands can be performed straight after one another,
first worked, second fails.
After that, every station on the network is locked out of the server. They get
connection errors. (Windows or Linux, it doesn;t matter.)

> Things you could do if you don't get a reply to this from someone that
> knows about server stuff:
> + compare config of the working and the failing server
>   (not just the samba config, network stuff too)
> + run the server with maximum log level and do the mount-thing
>   then follow the instructions on reporting bugs on the samba webpages
>   (if the logs are huge I am sure everyone will be happy with an URL
>    pointing to them)
> And please keep followups on the list. I'm just asking questions, doesn't
> mean that I can do anything constructive with your reply ...

Thats fine, like I said Ive worked around it. It is very strange though.

Steven Johnson
Managing Director
Neurizon Pty Ltd

More information about the samba mailing list