[SOLVED?] write_socket_data bug

Lee Howard faxguy at deanox.com
Wed Nov 15 19:01:33 GMT 2000

Folks, I think that my write_socket_data problems have been solved thanks
to a good pointer by someone last week on the list.

The system in question runs named in addition to smb, and I did not have a
reverse-DNS file set up for the local, private-IP (192.168.x.x), domain.
Since I did that on Friday afternoon these are my logs:

[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/13"
log.smb:[2000/11/13 16:01:39, 0] lib/util_sock.c:write_socket_data(540)
[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/14"
[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/15"
[root at virtue samba]#

Normally, this system has had about 10 write_socket_data errors per day
since the errors started occuring, so the logs listed above show a dramatic
improvement, and my guess would be that I probably won't see any more of it
in the degree that I have seen it before.

Thanks all,

Lee Howard

More information about the samba mailing list