[SOLVED?] write_socket_data bug

Steve McClary scm at mrwassoc.com
Tue Nov 21 00:23:22 GMT 2000

Lee -

This sounds like it might be the solution to the "Network is Busy" problem 
I've been having - can you describe the fix that worked for you? The 
"reverse DNS-file" comment in your post went past me <g>.


Steve McClary

At 12:01 PM 11/15/2000 -0700, you wrote:
>Folks, I think that my write_socket_data problems have been solved thanks
>to a good pointer by someone last week on the list.
>The system in question runs named in addition to smb, and I did not have a
>reverse-DNS file set up for the local, private-IP (192.168.x.x), domain.
>Since I did that on Friday afternoon these are my logs:
>[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/13"
>log.smb:[2000/11/13 16:01:39, 0] lib/util_sock.c:write_socket_data(540)
>[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/14"
>[root at virtue samba]# grep "write_socket_data" * | grep "2000/11/15"
>[root at virtue samba]#
>Normally, this system has had about 10 write_socket_data errors per day
>since the errors started occuring, so the logs listed above show a dramatic
>improvement, and my guess would be that I probably won't see any more of it
>in the degree that I have seen it before.
>Thanks all,
>Lee Howard

More information about the samba mailing list