Trouble with MS Excel files on samba share

Andreas Hoedle hoedle at
Fri May 5 14:36:55 GMT 2000

We are testing a basic setup using samba 2.0.6 from the SuSE Linux
distribution (Ver. 6.3). Copy files and working (loading & saving files)
with MS Word and other applications on the fileshare works well. With
Excel 97 SP2 running on NT4.0 SP5 we have the following problem :

Open the file first time -> o.k.
Save the file first time -> o.k.
Open the same file again -> o.k.
Save the same file again -> Excel claims no write permission or loosing
the Network connect

>From this point any other application connecting the samba share are
blocked too. We have reduced the test to one single machine connecting
the samba server and still have the problem that we can't save an Excel
file for the second time ???
I have tried to set the following parameters but none solved the problem

strict locking = yes   
blocking locks = no
oplocks = no

Could anybody give a hint what's going wrong?



More information about the samba mailing list