touch.exe problem with 2.0.6

Peter Belew pbelew at
Wed May 3 15:50:25 GMT 2000

We've had some trouble with the known problem with the Windows
touch.exe problem - it has no effect on a file on a system running
Samba 2.0.6. This has been reported previously with the MKS touch.exe,
and I have observed it with the Gnu touch.exe as well. Also, we
have some NT software which sets file dates using the Windows
SetFileTime() call, which is possibly what the MKS touch.exe uses,
and that fails to set the date with Samba 2.0.6; however, with a
1.9.x version, it works fine. In both of these cases, Samba is
running on a Sun system:

 SunOS miracle 5.5.1 Generic_103640-24 sun4u sparc SUNW,Ultra-Enterprise.

I have tried the Gnu touch.exe and also a program of my own, which
uses SetFileTime() to set a file's modification and access times,
on a RedHat Linux system, with no problem. This worked with RedHat
versions 6.1 and 6.2, running RedHat's builds of Samba 2.0.5a and
2.0.6 . Possibly, if this bug occurred in the Linux port of 2.0.6,
a patch was applied in the RedHat build.

Can anyone shed some light on this problem; what is the status
of this bug? (And did Red Hat actually patch their 2.0.6 version?)


Peter L. Belew
Sr. Software Engineer
Verity, Inc.

More information about the samba mailing list