FW: "unexpected network error occurred" when copying files

Beaver, Steve sbeaver at sud-chemieinc.com
Thu Mar 9 18:01:08 GMT 2000

I have done a little more investigating on this and have a little bit more

I set debug level to 3 and in my log file I am seeing this whenever I tried
to do a listing of my shared directory from my NT client:

[2000/03/09 11:20:10, 0, effective(301, 15), real(301, 0)]
 Failed to set uid privileges to (0,301) now set to (301,301)
[2000/03/09 11:20:10, 0, effective(301, 15), real(301, 0)] lib/util.c:(2456)
 PANIC: failed to set uid

Again, this is Samba 2.0.6 on Tru64 4.0F.

Thanks for any help that can be provided.


-----Original Message-----
From: Beaver, Steve 
Sent: Tuesday, March 07, 2000 4:39 PM
To: 'samba at samba.org'
Subject: "unexpected network error occurred" when copying files

Hello all,

This is my first posting to this listserv, so be gentle:-)

I have searched high and low for a resolution to my problem.  I have Samba
2.0.6 running on two Alpha 1200 servers with Tru64 4.0F.  The installations
are nearly identical and the first server is doing great, but the second one
is causing me problems.

I am able to write to and read from the first server I installed Samba to
using a WinNT 4.0 client.  Disk sizes are reported correctly.

When I try to copy a file from the second one or delete a file from it using
the same client, I get "An unexpected network error has occurred".  It
deletes the file OK, but when I write to the Samba server it creates the
file with 0 bytes size.  An "ls -l" from the OS confirms this size.  When
doing a directory listing on this server it is slow and tells me that I have
0 bytes free on the disk.  

We are using Advfs to create the filesystem on both Alpha's and the
filesystem sizes range anywhere from ~260 MB (root) to ~80 GB (database).
These errors occur no matter where my directory that is mapped to the samba
share is located.

What really bugs me is that the two servers are nearly identical.  The
differences are that on the first I have 1 GB memory and 2 GB on the second.
Also, the second has two network interfaces but I have compensated for that
by using the "interfaces" key in my smb.conf along with "bind interfaces
only = yes".  I have also tried removing the other network interface from
the network setup and removing the references to interface in smb.conf, but
no change with my problem.  I have also tried using "max disk size = 80000"
and "dfree command = /usr/local/samba/bin/dfree" with a dfree script (perm =
755) but no difference.  The first server running samba does not have these
settings but is reporting the disk sizes correctly.

Anybody (ANYBODY!) who can help me with this will received my everlasting
appreciation, and maybe a free dinner whenever you are in Lousiville, KY or
I am wherever you may be.

Steve Beaver


More information about the samba mailing list