NT server manager support/Failed RPC calls

Gerald Carter gcarter at valinux.com
Thu Aug 24 12:58:16 GMT 2000

Truman Lackey wrote:
> I am currently using samba 2.0.5a as a file server on 
> Redhat 6.1 with a NT controlled domain.  I am trying to 
> use the NT server manager to look at the shared directories 
> on the samba server and the RPC call is failing.  I have
> tried various smb.conf implementations with 
> different security levels, protocols and announce as, but 
> it never succeeds.  I have also tried the 2.0.7 release 
> with basically the same results.


Can you check out a copy of the latest HEAD branch CVS 
code and try to reproduce this?  With 2.2.0 close on the way,
it would be better to patch against that base if need be.

> From sniffing the network packets the command that is 
> failing is a 0x24 from the NT RPC server, and from 
> looking at the source code in smbd/ipc.c it appears 
> that this command is not supported.

What pipe is this on? samr i'm guessing.  I think that would

> What I am trying to do is to set permissions for NT 
> users for the share.  I do not necessarily want all users 
> on the domain to have access to the samba share and I also 
> do not want to set up users on the linux box.  From the
> server manager on the NT server you are able to create 
> new shares under a shared directory on the NT server 
> and are able to set permissions for the shares.

Ah...I see what you're doing.  Better to go back a 
read the smb.conf man page some more.  Use the 'valid users'
parameter for your current setup.

Cheers, jerry
   /\  Gerald (Jerry) Carter                     Professional Services
 \/    http://www.valinux.com  VA Linux Systems    gcarter at valinux.com
       http://www.samba.org       SAMBA Team           jerry at samba.org

       "...a hundred billion castaways looking for a home."
                                - Sting "Message in a Bottle" ( 1979 )

More information about the samba mailing list