PLEASE help with printing problem

Matthew Vanecek mev0003 at
Thu Sep 30 08:01:00 GMT 1999

I can't seem to find an answer or a workaround, and I've received stoney
silence on this one.  There aren't any answers in the archives (well, I
didn't find any in the hours on several days I spent, anyhow).  I'm
convinced that I can't be the *only* one with this problem, nor am I
convinced that there is absolutely no one who can help.  Please feel
free to jump in with ideas.  The problem follows:

I set up a new printer on my Linux box, an Epson Stylus Color 740.  I
had previously been using an EPson Stylus Color IIs.  I got the printer
working nicely in Linux, but I can not print to the printers I set up in
/etc/printcap via samba from NT anymore.  I.e., it worked with the IIs,
but not with the 740.  I didn't change anything in smb.conf.
NT lets me install the printers via samba, but not print to them.  It
always returns a message that "The parameter is incorrect".  Is there
any way to find out what parameter it's barfing on, and how to fix it?
Other symptoms include, NT can't view the print queue.  NT can't delete
print jobs (well, it can't see them, so how could it delete them?). 
I've tried various combinations of print commands, lpq commands,
printing, etc.  I've tried just about every type of printing available:
bsd, lprng, sysv, etc.  Instead of having a [printers] section, I've
tried using a different section for each printer in my printcap.

I've also tried setting print command = /usr/bin/echo "printed %s on %p"
>> /tmp/smb.print.  AFAICT, this command is never executed.  smb.print never appears in /tmp.  With the stock lpr, the file to print don't even appear in /var/spool/samba.  Well, a couple did, and are there, but they are a 0 byte size.
I checked the system and samba logs, and there's nothing there about
this.  I've also tailed them with a debug level of 3.  If I have a print
queue open in NT, the log says:

[1999/09/30 02:55:11, 3] smbd/ipc.c:api_DosPrintQGetInfo(823)
  PrintQueue uLevel=2 name=lp360
[1999/09/30 02:55:11, 3] printing/printing.c:get_printqueue(1011)
  Running the command `/usr/bin/lpq -Plp360' gave 0
[1999/09/30 02:55:11, 3] smbd/process.c:process_smb(615)
  Transaction 298 of length 117
[1999/09/30 02:55:11, 3] smbd/process.c:switch_message(448)
  switch message SMBtrans (pid 30722)
[1999/09/30 02:55:11, 3] smbd/ipc.c:reply_trans(3614)
  trans <\PIPE\LANMAN> data=0 params=33 setup=0
[1999/09/30 02:55:11, 3] smbd/ipc.c:named_pipe(3471)
  named pipe command on <LANMAN> name
[1999/09/30 02:55:11, 3] smbd/ipc.c:api_reply(3416)
  Got API command 70 of form <zWrLh> <zWWWWzzzzWWzzl>
[1999/09/30 02:55:11, 3] smbd/ipc.c:api_reply(3420)
  Doing DosPrintQGetInfo
[1999/09/30 02:55:11, 3] smbd/ipc.c:api_DosPrintQGetInfo(823)
  PrintQueue uLevel=3 name=lp360
[1999/09/30 02:55:11, 3] printing/printing.c:get_printqueue(1004)
  Using cached lpq output

My current smb.conf printing related stuff is as follows:

printing = bsd
printcap name = /etc/printcap
load printers = yes
print command = /usr/bin/lpr -r -P%p %s 
lpq command = /usr/bin/lpq -P%p 
lprm command = /usr/bin/lprm -P%p %j 
comment = All Printers
path = /var/spool/samba
browseable = True
printable = yes
public = True
writable = no
create mode = 0700
I have samba 2.0.5a, NT WS 4.0, SP5, and the Epson printer
drivers/software.  I'm kinda wondering if the Epson software is getting
in the way, but it won't let me install the drivers without installing
the software.  However, if I could massage the parameters samba receives
a little, I might be able to get it to work...if I knew how to capture
the parameters.

I'm at my wit's end on this one.  Surely *somebody* knows something
about how to fix this?

Matthew Vanecek
Course of Study:
Visit my Website at
For answers type: perl -e 'print
For 93 million miles, there is nothing between the sun and my shadow
except me. I'm always getting in the way of something...

More information about the samba mailing list