samba 2.0.5a, solaris 2.6, pam

Liam Hoekenga liamr at
Wed Sep 29 03:57:18 GMT 1999

I posted earlier, but didn't really include and information...

I'm trying to get samba compiled on Solaris 2.6 with PAM support, on an
Ultra 60 with 1GB RAM, and a bunch of disk
I've tried using sun cc (from sunworkshop 4.2), and gcc version 2.8.1

I've tried using /usr/ccs/bin/make and gmake v 3.76

libpam gets compiled into my binaries, but they don't actually seem to use

passdb/pass_check is the only code that actually tries to include
<security/pam_appl.h>, so I'm assuming the stuff in passdb gets built into
all the binaries for password checking.  I get errors when trying it tries
to compile that particular bit o' code:

	Compiling passdb/pass_check.c
	"passdb/pass_check.c", line 93: warning: initialization type mismatch
	"passdb/pass_check.c", line 750: warning: statement not reached

When I truss the nmbd and smdb proccesses, it doesn't check pam.  I'd
normally expect to see something like:

	stat64("/etc/pam.conf", 0xEFFFE540)             = 0

Samba works fine otherwise.  I'm using an smbpasswd file... but I need to
be able to further restrict access through pam.

Does anyone have any suggestions?


More information about the samba mailing list