RH6.0 - Samba 2.0.3 - Win98 - With a Twist

Allen Hubble AHubble at idirect.com
Wed Sep 29 00:58:34 GMT 1999

Hi All,

Here's my problem, when I first set it up, I could connect using smbclient
from the Linux box (localhost)<Great!>.  When I tried from the Win98 command
line, I got the 'Error XX...Bad Password' error.  After researching things a
bit, I was lead to get out tcpdump to see what was going on.  In the tcpdump
output I could see my userid and (to my surprise,) my workgroup where the
password should have been! <Grumble, grumble.  More research...>

I implemented the EnablePlainTextPassword fix suggested here,
http://us1.samba.org/listproc/samba/October1998/0321.html because the
symptoms sounded the same.  Now when I try it with tcpdump, I see neither my
userid nor my password and I still get the same error.

This only happens when I try to access one of the shares that has some sort
of security on it (i.e. I can connect and browse the tmp share, no problem).

To save bandwidth, my smb.conf file (which has been modified both manually
and using linuxconf) can be found at http://www.hub-tech.com/smb-conf.txt.

In thinking about the workgroup-rather-than-password issue, I noted that my
Win98 network config is set with 'Share-level access control' but I can't
see how that is relevant.  Isn't that just for shares that are defined on
the Win98 system?  I'm stumped at this point thus my post.
Allen Hubble <AHubble at Hub-Tech.com>
Hubble Technology Consulting, Inc.
Progress/UNIX, Mfg/Pro, EDI/EC
Brampton, Ontario, Canada
*************** Fortune favours the BOLD! ***************

More information about the samba mailing list