NT-to-Linux printing stopped working...

Matthew Vanecek mev0003 at unt.edu
Sat Sep 18 19:30:04 GMT 1999

Printing seems like a popular subject here lately. ;)

I have an Epson Stylus Color IIs which I had connected to my Linux box. 
It was mapped on my NT box, and everything worked fairly well (except
for the print quality--NT drivers for that printer suck).  So, I bought
a new printer--an Epson Stylus Color 740.  I hooked it up to Linux, made
the necessary changes to /etc/printcap, and printed some test pages. 
Works great.  So I restart samba.

Then, I go to NT and install the printer's drivers, open up NN, select
one of the three virtual printers I made, and install it.  No problem. 
However, when I tried to print a test page, the operation timed out. 
Somehow or another, the printing subsystem is unable to find the

I captured one of the printers to the lpt1 port, and it works that way,
but I'm not able to use the other queues I made, for the various
resolutions.  Has anyone had this problem before, or does anyone know
where I might look to fix it?

Using samba 2.0.5a.  I didn't change smb.conf at all between the two
Under [global] I have:
printing = bsd
printcap name = /etc/printcap
load printers = yes

my printers section:
;*******************section printers*****************
comment = All Printers
path = /var/spool/samba
browseable = True
printable = yes
public = True
writable = no
create mode = 0700

Matthew Vanecek
Course of Study: http://www.unt.edu/bcis
Visit my Website at http://people.unt.edu/~mev0003
For answers type: perl -e 'print
For 93 million miles, there is nothing between the sun and my shadow
except me. I'm always getting in the way of something...

More information about the samba mailing list