oplock_break problem

Jay D. Anderson Jay.Anderson at dw.deere.com
Fri Sep 10 12:14:12 GMT 1999

I have been plagued by the oplock_break problem ever since I first tried
to go to Samba 2.0.1.  I have tried successive versions of Samba as it
has been released, but the problem still occurs.  Because of a change in
2.0.x that fixes a problem with saving AutoCAD files, and better
handling of guest access for print queues, I run a small Samba 2.0.x
server that is used very lightly, and I never have any problems.
However, my main Samba server with 200+ users must remain on 1.9.18p10.

I believe the problem that occurs is that oplocks are left hanging on
the server, and are never removed.  After a period of time, all the
shared memory that is allocated to file locking is filled, and the
server starts sending garbage back to the clients when they request
locks, confusing the clients and creating all sorts of strange behavior.

This would explain why lightly used servers will not see the problem,
and why Samba 2.0.x functions well for a period of time then starts

There are so many great features in Samba 2.0.x, I'd really like to
start using it in production.  I hope the Samba team can come up with a
solution to this problem eventually, but to this point I get the feeling
they don't even recognize this as a problem.

I am running Samba on Solaris 2.6, with Win95, WinNT and WTS clients.

Jay D. Anderson                         John Deere Davenport Works
Jay at Deere.com                           P.O. Box 4198
Phone: 319.388.4268 Fax: 319.388.4159   Davenport, Iowa 52808
http://www.dw.deere.com/~hz01930  http://web.infoave.net/~jaya

More information about the samba mailing list