Samba on Solaris 2.5.1?

Urban Widmark urban at
Fri Oct 29 16:19:37 GMT 1999

(I have experienced a minor mail snafu, so any mail sent to me via this
 list today is probably gone, except for this one. Fortunately Roberto
 included a lot of the previous comments)


> >Could you give me some more details about the installation
> >you have working?  What version of samba are you using?
> >Where did you get the binary?  Did you compile it yourself?
> >Any issues?  What kind of stuff are you doing in your smb.conf
> >file?

2.0.5a, compiled myself using gcc (
The smb.conf is basically unchanged from the example, except for possibly:
   allow hosts = ...
   security = user
   encrypt passwords = yes

; did I write this or copy it?
   comment = Home Directories
   browseable = no
   writable = yes

; enabled only for testing
    comment = Temp dir
    path = /tmp/foof
    browseable = yes
    guest ok = yes
    guest account = nobody
    public = yes

The only issue was NT4SP3 and encrypted passwords (giving a strange error
message on the NT side and then simply disconnecting).

> >We use nt-encrypted passwords, and have been using
> >smbpasswd to add existing unix-side username/password
> >pairs into samba's nt password file.  We use 'hosts deny all',
> >'hosts allow abc.def.0.0' to add that extra layer of access

You do have
  hosts allow = 127.
so that localhost is allowed in? Doesn't affect smbpasswd but still.

> >Our sa found a 2.5.1 pre-compiled binary.  He also found a readme
> >file that said the 2.6 binary would *not* work, so I don't think we
> >ever tried it.  We tried it several times on more than one machine,
> >and played around quite a bit.  

Like the previous speaker, I'd try to compile it myself if I were you, but
I really don't know what's wrong. Where did you find the pre-compiled
thing? I could dl it and see if it works on our machine.

> >There are rumors in our organization that someone had samba
> >working for a day or two on solaris 2.5.1, but then it stopped
> >working, never to work again, and that those guys then switched
> >over to pc-nfs, or such.

This same machine used to be in a different place a year or so ago. And
then we had 1.9.18? running on it, again without problems. OTOH, samba
access to it is simply because some of our NT people want to be able to
edit/copy files on it without having to use difficult things like vi, so
there is almost no load at all on the samba server.

But maybe you have it running by now?


More information about the samba mailing list