Samba on Solaris 2.5.1?

Roberto Joao Lopes Garcia roberto at
Fri Oct 29 13:36:43 GMT 1999


I have Samba 2.0.5a runing on Sparc Solaris 2.5, compiled with gcc 2.8.1 by
myself. It is very easy, just follow the instructions and voila!!!

We have +/- 50 clients and work very fine.

I sugest you to compile and install yourself for the Solaris 2.5.1. Do not
use cc (does not work for me), use gcc.


At 21:28 29/10/99 +1000, you wrote:
>Urban -
>Thanks for the information.
>It's very encouraging to hear that someone has it working
>(and I would have been very surprised if no one did...).
>Could you give me some more details about the installation
>you have working?  What version of samba are you using?
>Where did you get the binary?  Did you compile it yourself?
>Any issues?  What kind of stuff are you doing in your smb.conf
>Let me give you some more detail about what I'm doing.  I started
>by downloading a pre-compiled version of samba for solaris 2.6.
>I'm pretty sure that it came set up as a solaris 'package'.
>It worked from day one.  (Actually, I never got browsing working
>properly --- i.e., the samba servers aren't reliably browseable ---
>but I didn't try very hard, because I don't care.)
>We use nt-encrypted passwords, and have been using
>smbpasswd to add existing unix-side username/password
>pairs into samba's nt password file.  We use 'hosts deny all',
>'hosts allow abc.def.0.0' to add that extra layer of access
>control to our system.  I'm working with one of our unix
>sa's to get this going.  He's really quite good, but new to
>We now need to run samba on a couple of solaris 2.5.1 machines.
>Our sa found a 2.5.1 pre-compiled binary.  He also found a readme
>file that said the 2.6 binary would *not* work, so I don't think we
>ever tried it.  We tried it several times on more than one machine,
>and played around quite a bit.  
>There are rumors in our organization that someone had samba
>working for a day or two on solaris 2.5.1, but then it stopped
>working, never to work again, and that those guys then switched
>over to pc-nfs, or such.
>Our basic problem now is that smbpasswd hang indefinitely,
>and attempts to get around this by copying a password file
>from a working 2.6 installation cause attempts to connect
>to fail with unfamiliar errors.
>I'm a little foggy on the details, since the bulk of our attempts
>were some time ago.
>I will go ahead and repeat the samba diagnostic procedure
>(taking notes) and report back anything noteworthy.  In the
>meantime, any info about your working installation and how
>you got it configured would be very much appreciated.
>Urban Widmark <urban at> wrote:
>> On Fri, 29 Oct 1999, Frank R. Brown wrote:
>> > Does anyone have Samba working on Solaris 2.5.1?
>> Yes.
>> > I have Samba 2.0.0 running successfully on Solaris 2.6,
>> > but have failed in repeated attempts to get Samba running
>> > on Solaris 2.5.1.  Basic symptom:  I can get the daemon
>> > running, but can't connect to any shares, *and* can't use
>> > smbpasswd to 'add' new user id's (smbpasswd just hangs).
>> > 
>> > Any advice?
>> Try something more recent than 2.0.0? Not that I know of any bugs in
>> 2.0.0 (but if that version was perfect why release anything after it :)
>> What do you connect from? If NT4SP3+ you need encrypted passwords or tell
>> the NT to use unencrypted. Well, you are of course using smbclient to test
>> from localhost, so that can't be it.
>> I believe someone mentioned some problems with copying one installation
>> from one machine to another. Something to do with the SHARE_MEM_FILE in
>> /usr/local/samba/var/locks/  ?
>> Are you trying to run a 2.6 binary on the 2.5.1? Don't know if/why that
>> would cause problems but I guess it could ...
>> Sorry, that's the best my tired brain is capable of right now.
>> /Urban
>     Frank R.Brown
>     Frank.R.Brown at MailAndNews

More information about the samba mailing list