SAMBA config problem

Richard Rahders rahders at
Sun Nov 21 00:32:26 GMT 1999

We are a little stuck on this one;
running /usr/sbin/smbd = version 2.05(a) from Red Hat 6.1, kernel 2.2.12-20,
we can't log on to our Linux server from our W 98 boxes.  We can telnet in
just fine, but it won't show up in any network neighborhood on the PCs....

We're trying to get SAMBA to run on the Linux server so we can run seven W98
clients for a small law office.  Nothing complicated, just want to run ADSL
into the Linux box, do IP masquerade, and have SAMBA on the server for files
etc. with WordPerfect 8.0 Legal Edition on each workstation.  We just have a
private internal net for them starting with (the server) and up
from there (22,23,24,etc.).  We can't get the clients to see the server...
Guess what, I've never done it before.  I know this SHOULD be simple, but
I'm missing something..

I've worked through the DIAGNOSIS.txt from Andrew Tridgell and we can get
through Test 1, 2, 3 just fine... test 4 we get the loopback; test 5 doesn't
work and we can't figure out why; test 6 the same, no work, no figure; test
7 worked; test 8 gave error 86 from dos prompt ("specif. net passwd not
correct"); test 9 gave error 53 from dos prompt ("computer name cannot be
located"); and test 10, can't browse the server.

I'd be happy to send the testparm results if anyone is interested, or, if
someone has an actual smb.conf file for a little net like this that works
I'd love to look at it....  I'd send anything else too if it would help....

Could someone help us with this, or refer us to somebody who could?  We're
trying to get Linux servers started in some small businesses here in Santa
Cruz and we DON'T want to go back to NT....
Thanks much!

Richard Rahders
Santa Cruz, CA.

More information about the samba mailing list