Bug report: smbmount 2.0.6 and NT pagefile.sys bug

Gavrie Philipson gavrie at netmor.com
Mon Nov 15 08:59:17 GMT 1999


I have just installed Samba 2.0.6 and noticed that the "pagefile.sys"
smbmount bug still exists:
When unsing smbmount to mount an NT4 volume, and doing an "ls" on the
mounted directory, I get:

# ls /mnt
ls: pagefile.sys: Permission denied
.                  IO.SYS             SRVMGR.EXE        
ffastun.ffa        summary.dat
..                 KBROWSER           SRVMGR.HLP        
ffastun.ffl        sysback

The smbfs code seems to have a problem stat'ing the pagefile.sys file.
When trying an 'ls pagefile.sys', I get the same:

# ls pagefile.sys
ls: pagefile.sys: Permission denied

Note that when accessing this share with smbclient, the pagefile.sys
file can be viewed correctly. This means that the NT permissions are OK,
and that the bug is in the smbmount code.
This bug has been reported on the Samba mailing list and on the Linux
kernel mailing list before. With Linux 2.0 kernels, this worked fine.
The 2.2 kernels broke it.

As smbmount wasn't officially a part of Samba, I haven't raised this
lately on the list. Now that it is, I hoped that it maybe would be
solved in 2.0.6. So -- Jeremy, Tridge, whoever -- any ideas on this

Note that answers such as "you shouldn't access pagefile.sys anyway"
aren't particularly helpful.
For the interested, I'm running an automated smbmount-based backup
utility to backup our Windows machines. The utility *is* instructed to
ignore pagefile.sys, but it fails on stat'ing the directory listing --
long before it even tries to read pagefile.sys. So this really has to be
fixed, guys...



Gavrie Philipson
System Administrator
Netmor Applied Modeling Research Ltd.

More information about the samba mailing list