Problems with multiple samba servers on subnets

Tindall, Mark MTindall at
Thu Nov 4 14:46:51 GMT 1999


we are in the process of moving from TAS to SAMBA, and as such are setting
up various servers. I have already successfully set-up and configured one
server running on Solaris 2.6 in a domain on an E10000. The problem we are
having is replacing other instances of TAS with SAMBA. We have so far
unsuccessfully tried to set up another SAMBA server on a Sparc1000 running
on the same subnet but with another network card. I have tried to go through
the DIAGNOSIS.txt file to run the various tests, but cannot get past test
no. 8 from a PC:

	c:> net view \\<SAMBA SERVER>

This has come up with different errors: 
	The remote procedure call failed
	Invalid network name
I checked this command against the first server I set up and it works fine.
So I copied the smb.conf file across and changed a few values, which again
when tested produced the same results above. If you are on the UNIX server
and issue a smbclient command, there are no problems. The same sort of thing
happened when I tried it on an another machine which was on a different
subnet, though the PC clients on this subnet can see it with no problem, yet
no-one else can.

Could somebody give me some clues as to where I am going wrong and point me
in the right direction to solve these problems.

I have enclosed the smb.conf file from the server that is on the same subnet
as the one that is working ok.

# from (
# Date: 1999/11/04 13:47:13

# Global parameters
	workgroup = DERWENTINF
	netbios name = ATLED
	server string = %h Samba Server
	interfaces =
	bind interfaces only = Yes
	encrypt passwords = Yes
	password server = ATLED
	passwd program = /usr/local/samba/bin/smbpasswd
	username map = /usr/local/samba/lib/
	read size = 8192
	socket options = TCP_NODELAY
	lm announce = True
	local master = No
	browse list = No
	wins server =
	unix realname = Yes
	admin users = root mtindall sburch mwaller
	hosts allow = 194.202.25. 193.128.218. 10.1.1. 10.1.4. 
	queuepause command = enable %p
	short preserve case = No

	comment = Home directories
	username = %S
	read only = No

	comment = Shared Printers
	path = /var/spool/samba
	create mask = 0600
	print ok = Yes
	postscript = Yes
	print command = /usr/bin/lp -d%p %s ; rm -f %s
	lpq command = /usr/bin/lpstat -p%p
	lprm command = /usr/bin/cancel -p%p %j
	browseable = No

	path = /tmp
	read only = No
	guest ok = Yes
	hosts allow = 194.202.25. 193.128.218. 10.1.1. 10.1.4.

Thanks in advance

Mark Tindall
System Analyst
Derwent Information
Tel: 0171 424 2093
Email: mtindall at

More information about the samba mailing list