smbmount syntax for 2.0.5a

Mader, Cary J cary.mader at
Mon Nov 1 21:10:37 GMT 1999

I've got a SuSE 6.2 Linux server, which now comes with Samba 2.0.5a.  I'm
having problems with scripts that used to run under 2.0.2.  

I've tried digging around on newsgroups, the manpages, and the Samba web
site and can't seem to find everything I need to do to mount a share (from
an NT 4.0 server). 

When I issue the following:

smbmount //server/share -I dest ip -U user%pswd -c `mount /mnt/dirname`

I get the following message:
mount: can't find /mnt/selData in /etc/fstab or /etc/mtab

What do I need to do to configure the fstab and or mtab files so that the
smbmount command will work?  Or am i doing something wrong on the smbmount
command? Should the /mnt/dirname directory exist (I've created one)?

 I tried adding a line to fstab using filesystem option smbfs, which was in
the man page for mount, but then got an error that it was an invalid
filesystem.  The mount man page also mentioned a script file named
mount.smb, but did not provide much other detail.


More information about the samba mailing list