samba and SMP

Mike Squires msquires at
Mon Nov 1 04:25:42 GMT 1999

I've now tried 2.0.6pre2 with a SuperMicro P6DNF dual PPro as well as
the Everex StepDP/Pro dual PPro MB; same result,
large (more than 1 MB) file copies usually crash with only a message about
oplock errors in the logfile.  Running a single CPU kernel works fine
(pre2 seems much faster, but I haven't done any testing).

2.0.5a does the same.

NFS and mars_nwe with the same hardware and SMP kernel work fine, even with
very large files (GB) and high throughput (3MB/sec sustained).  There are
no hardware errors reported at any time; memory passes AMIDiag's pattern
testing without a peep.  The SM used completely different hardware and a
fresh installation, by the way.

Client is an NT4 SP5 workstation; have tried both server and domain authentication.

I have many KB of mptable/kernel config files/log files, but none of it seems
very helpful.  I suspect that a sniffer will be required to do a packet trace.

Any suggestions?

Mike Squires

More information about the samba mailing list