Problem with IIS and Samba 2.04b

Yann Doussot doussot at
Sun Jun 27 12:50:40 GMT 1999


	I recently upgraded from samba 1.9.18 to 2.04b and now have a
strange problem. My setup:

- Linux 2.2.7 with samba 2.04b (not domain controller)
- NT 4sp3 (domain controler) with IIS 4

	From the NT I can browse shares on the Linux server without any
problem, everything works as exepected. Some virtual hosts on the IIS
server are configured to use a directory on the Samba server as their
document root. I works fine except for the default index document. For
example http://myserver/ returns 404 not found, it does not find the
index.asp file which exists and is readable by the NT. IIS has been
configured to use index.asp as the default index. It works fine if the
document tree is on the server and it worked fine with same 1.9.18. A
direct call to htt://myserver/index.asp works.

	I'm not sure the problem come from samba but it worked with older
version and I did not change anything on the NT server. Any ideas ?

	Thanks in advance.

(Please CC me answers, I'm not subscribed to the list)

Yann Doussot <doussot at>
Grey Interactive - France -
Cell: +33 6 12 71 70 03   Work: +33 1 46 84 85 00

More information about the samba mailing list