smbmount -- what am I missing?

Lance Simmons simmons at
Tue Jun 22 03:33:28 GMT 1999

I wish to mount a Win95 share on my linux machine.  I can use smbclient
to get to the shared disk, using this format:

    smbclient //win95.machine/share <password>

The win95.machine is listed in my /etc/hosts file.

I've tried every permutation of the smbmount syntax that I've been able
to find in the documentation, dejanews, or this mailing list. Perhaps
I've missed some. I always get the same error message:

  Session request failed (131,130) with myname=<MYLINUXMACHINE>
  Called name not present
  Try to connect to another name (instead of <WIN95.MACHINE>)
  You may find the -I option useful for this

Does the IP address of WIN95.MACHINE need to be somewhere other than in
my /etc/hosts file? Does the fact that the name of the server is of the
form "WIN95.MACHINE" make a difference? Do I need to change something on
the win95 machine itself?

Why does smbclient work and smbmount give me this error? Can smbmount be
made to work?  If not, is there some other way I can mount a win95 share
on a linux client?

This problem arises on two different linux machines, one running RedHat
6.0, the other running Mandrake 6.0, and I've had the same problem
running RedHat 5.2 in the past.

I must be missing something fairly fundamental, but if smbclient works,
it seems that in principle I should be able to get smbmount to work...

Any help would be much appreciated.

Lance Simmons

More information about the samba mailing list