Multiple configuration problem

mdgabrie at mdgabrie at
Fri Jul 9 22:20:25 GMT 1999

I'm having a perplexing problem with a multiple configuration setup. My
setup was working fine until I changed the IP address of my server. Since
then, Samba has been misbehaving. All other networking processes are
working fine so I don't believe it to be a o/s issue on the system. The
system is running Solaris 2.6 using Samba 2.0. My client and the server are
on the same TCP/IP class, a trace route shows that I am going directly to
the server (after performing the necessary dns lookup).

Again, my configuration was working correctly until I changed my IP
address. However, I have tried everything I can think of the verify the
correctness of the samba setup. By the way, I changed my IP address using

The problem is that I am able to obtain the shares from 'server2' but
cannot obtain shares from 'server2secured'. When I map a drive from my pc
(NT4.0), it says 'the network path was not found.'

My smb.conf file has:
    netbios name=server2
    netbios alias=server2secured

My smb.conf.server2 file has:
   security = share
   server string = Eng File Server

My smb.conf.server2secured file has:
   security = domain
  server string = Eng File server

I joined the Samba server as a member of the NT domain. Since my problems,
I have deleted and re-added it. Didn't help.

I put the portion of the smb.conf.server2secured file into smb.conf
(commenting out the include) and I was able to see the shares. But once I
go to multiple configurations, I cannot see the 'server2secured' shares.

When I put an entry into my local hosts file for 'server2secured', I am
able to obtain shares but it is the shares for 'server2' not for

When doing 'nmblookup -B server2 __SAMBA__', I receive:
   Sending queries to __SAMBA__<00>

When doing 'nmblookup -B server2secured __SAMBA__', I receive:
  Sending queries to __SAMBA__<00>

When executing "smbclient '\\server2\share'", I receive the smb> prompt.
When executing "smbclient '\\server2secured\share2'", I receive the smb>

>From a DOS box, 'net view \\server2' properly shows its shares.
But 'net view \\server2secured' returns 'System error 53 has occurred. The
network path was not found.'

What is happening??? Sorry for being so long, but I wanted to include
everything I've tried (I hope I haven't left something out).


Mike Gabriel
Rockwell Collins

More information about the samba mailing list