oplock problem (PR#18690)

Jeremy Allison jallison at cthulhu.engr.sgi.com
Tue Jul 6 23:27:49 GMT 1999

tkuba at seznam.cz wrote:

> This program is installed locally on win9x/NT and shares its databases. We
> tried to place databases on novell, on NT server and on win95 acting as
> server and everything worked fine. But when we tried to run this program
> with databases on samba server under linux, the problems began. It was
> possible to start several instances of program on the same computer, but
> when we started program on another computer, the program returned something
> like "On another computer is running operation that needs exclusive access
> to databases. Stop this operation and try to run program once again". That
> error message should appear only if somebody is trying to re-index or
> backup databases.
> The only way we were able to run the program on more than one machine was
> to set "fake oplocks = yes" which isn't very happy in network environment.
> So the problem seems to be with oplocks.
> Is there some difference between samba's and win9x/NT's oplocks?
> Does anybody know the solution of this problem?

What version of Linux ?
What version of Samba ?

Please be more specific if you need help :-).


	Jeremy Allison,
	Samba Team.

Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.

More information about the samba mailing list