Can't run certain executables (PR#12624)

Jeremy Allison jallison at
Wed Jan 13 20:48:41 GMT 1999

> I'm truely sorry to bother your group.  But I don't know if this is a bug or
> not.  I've tried to find help on the samba news group and on the IRC to no
> avail.  I've also have the Samba book by John D. Blair.  I've attached my
> smb.conf file.  I have full access to the share (read/write/execute).  But for
> some reason, when I try to run certain executables such as the netscape install
> executable, McAfee setup.exe, and others.  The error that I receive when I try
> to run such an executable from NT is "Cannot find P:\setup.exe.  Windows needs
> this file to run P:\setup.exe".  I have the share mapped to the p: drive
> letter.  This doesn't happen with all executables.  Just some.  And it seems to
> be localized to just installation executables.  If you don't have time to help
> me, could you pass me on to someone that could help me figure this out?  Thanks
> for your time.
> -- 
> Chris Dos
> Corporate Administrator


	This is actually a well known bug in NT w.r.t running
16 bit executables from a directory containing long filenames.

To fix it in your current setup, create a 8.3 name symlink on
the UNIX side to point to the long filename directory and run
the 16 bit executables from there.

The good news is that we have worked around this for Samba2.0
and 2.0 will allow NT to run 16 bit executables from a longfilename
directory correctly.

2.0 is due out any day now (as soon as I finish my regression
tests.... :-).

Hope this helps,

	Jeremy Allison,
	Samba Team.

Buying an operating system without source is like buying
a self-assembly Space Shuttle with no instructions.

More information about the samba mailing list