Communicator 4.5 & Samba 2.0.0

Jim Morris Jim at
Thu Feb 4 04:11:08 GMT 1999

I've been playing with upgrading from Samba 1.9.18p10 to Samba 2.0.0,
since the day 2.0.0 was release, off and on.  I've experienced quite a
few problems - a lot more than I had hoped to see with 2.0.0.  I've been
doing all my testing on my small LAN here at home, using a Win95 PC and
a Linux PC running Redhat 5.2 and Linux 2.0.36.

The primary problem I had up until now related to the fact that Samba
2.0.0's configure script sets Samba up to be compiled with Shadow
password support on Redhat 5.2 (Linux 2.0.36), even if you aren't using
shadow passwords. Short of editing the generated config.h, there is no
way to turn the use of shadow passwords off when running configure (not
that I've found anyway).  The workaround for me with this problem was to
switch to shadow passwords, using the shadow-utils that installed with
Redhat 5.2...

Ok, now that I am authenticating users, I have really seen some strange

I run Netscape Communicator 4.5 on my Win95 notebook PC with the mail
folders stored on a Samba share on the Linux machine, and have about
120MB of mail folders (what can I say - I save everything!).  The samba
share is a FAT32 volume that is also used when the server is booted into
Win95.  This has been working fine for over a year now, with Samba
1.9.18p10 (and earlier versions), and with Win95 as the server too.

With Samba 2.0.0 installed, I can open a DOS box, and browse the share,
and edit files with a text editor (Vim for Win32), and create new files.
I can open the Netscape folders (standard Unix mail folder files) and
view them from the text editor.  What I CANNOT do is see my mail folders
with Netscape Communicator!  It sees the contents of the Inbox, but
thats it. It does show a full list of all the folders in the mail
directory, but cannot see the contents of the mail folder file(s).

Reverting to Samba 1.9.18p10 and issuing a "samba restart" command on
the server immediately corrects the problem.

I have tried building Samba 2.0.0 myself from the source, and have used
the two binary RPM's on the Samba mirrors (samba-2.2.0-1.i386.rpm and
samba-2.2.0-990115.i386.rpm).  I have also tried using Swat to make sure
my smb.conf didn't have any options in it that would be causing this. 
I've tried turning features like oplocks off, and strict locking on. 
I've messed with the filename case options.  No dice.
Does anyone have any thoughts on this issue? Has anyone else seen a
problem similar to this with Samba 2.0.0, that doesn't occur with

Thanks for any input!

For reference, just what I feel are relevant parts of my smb.conf are
below.  The shared called "d" is the share I have my Netscape folders
on. It is mounted in fstab like this:

     /dev/hdc3     /dosd          vfat             rw,umask=000 0 0

Mounting with these options allows normal users (non-root) to have r/w
access to the mounted Win95 partition.

Anyway, here goes:

---------- smb.conf excerpt ------------
# Filename case preservation options
preserve case = yes
short preserve case = yes
default case = lower
case sensitive = no

# File locking options (JFM)
locking = yes
strict locking = yes
oplocks = false
share modes = yes
lock directory = /var/lock/samba

# File creation & timestamp options (JFM)
dos filetimes = true
create mask = 0750

# Read prediction enables read-ahead for files opened in read-only mode
read prediction = true

comment = Win95 D drive
path = /dosd
public = yes
writable = yes
printable = no
write list = @users
available = yes
guest only = no
browseable = yes
only user = no
---------- end smb.conf excerpt -------------

Thanks for any advice! 

| Jim Morris  |  jim at |

More information about the samba mailing list