Solaris 2.6 Samba 2.0.4b Server <-> Win 3.11 Client struggle

Troy Johnson john1536 at
Fri Aug 20 22:18:40 GMT 1999

I have struggled with compiling 2.0.5a on Solaris 2.6 with gcc version
2.8.1 for the last couple of weeks (not a high priority project) and
decided to try a precompiled version just  in case I was being stupid.
Well, perhaps I'm stupider (is that a word) than I thought because I
installed the package and I still cannot connect. I have read through
the docs and tried more than a few configuration options, but something
isn't clicking the way it should.

Here are the details:

The win 3.11 client will intermittantly be able to see the Samba server,
but never sees its shares, and cannot use the netlogon (windows just
dies) (this is what I'd like to work into, but I have tried far more
spare configuration files). Having the samba server listed as it's
primary WINS server helps, but not enough to see shares (but it does
allow the netlogon->windows_dies problem to happen (my idea of progress
is quite dismal at this point)). I can connect with smbclient just fine,
but smbstatus sometimes gives errors like this (compiled by me or
packaged by others):

Samba version 2.0.4b
Service      uid      gid      pid     machine
ERROR: Failed to initialise share modes!
Can't initialise shared memory - exiting

but seems to provide normal output after using smbclient.

My smb.conf file is here (beware: could contain really stupid mistakes,
please help):

workgroup = MCSS
netbios name = COUNT
netbios aliases = COUNT5
server string = MCSS Samba Server
hosts allow = 127.
log file = /opt/samba/var/log.%m
max log size = 50
security = share
;security = user
;socket options = TCP_NODELAY
wide links = no
os level = 33
domain logons = yes
logon home = \\%N\%U
logon drive = h:
logon path = \\%N\%U\profile
logon script = START.BAT
allow trusted domains = no
local master = yes
domain master = yes
preferred master = yes
wins support = yes
wins proxy = yes
max disk size = 200
comment = Logon Directory
path = /opt/samba/share/netlogon
browseable = no
writeable = no
printable = no
comment = Home Directories
browseable = no
writeable = yes
user = @mcss
comment = Public Directories
path = /opt/samba/share/public
public = yes
writeable = yes
printable = no
writelist = @mcss
user = @mcss
comment = PC Directories
path = /opt/samba/share/%m
public = no
writeable = yes
writelist = @mcss
user = @mcss

Any help would be appreciated, and please don't be too harsh in
reprimanding me for silly mistakes. I have read through most of the docs
(anything I thought could apply (lots of those)), and searched for
answers on the Samba web page. Thank you,

Troy Johnson

More information about the samba mailing list