Easy Solaris2.5.1/Samba2.0.3 ???

Franden, Craig CFranden at MAIL.co.washoe.nv.us
Tue Aug 17 19:47:25 GMT 1999


I only recently started using the Samba product on our Solaris 2.5.1 server.
I am using it for the sole purpose of creating unix type queues (actually
win clients with attached printers) to allow a 3rd party application (using
Oracle8.0.4) to print to client pc's.  The 3rd party application will only
print via a unix queue.  Below is the error I receive when trying to use

>smbclient \\\\dctrain1\\HP4_PLUS
Added interface ip=xxx.xxx.224.161 bcast=xxx.xxx.255.255 nmask=
Got a positive name query response from xxx.xxx.224.151 ( xxx.xxx.228.6 )
session setup failed: ERRDOS - ERRnoaccess (Access denied.)

(understand that the xxx.xxx is the same set of octets in every instance.)

Obviously, smbclient is having problems negotiating a session, I was hoping
that somebody could point me in the right direction as to resolve this

When I run "smbclient -L" I am able to see the win client with no problem.
When I run "testprns printer" the result indicates a valid printer in
lpstat, yet when I try to send a job to the printer the following is
	Your request class1-224 destined for printer
            The job title was:      .test
            submitted from:      unix server
            at:      Mon Aug 16 10:45:03 1999

	encountered an error while printing on printer class1.
	Printing stopped with an exit code of 1.

	Reason for failure:
	/bin/sh: /etc/lp/interfaces/printer: not found

I know that the /etc/lp/interfaces/printer exists, because I created it
using lpadmin and the smbprint.sysv parameters.

Any help would be greatly appreciated.


Craig Franden, MCP
Database & Network Administrator
2nd Judicial District Court
75 Court Street
Reno, NV  89520

More information about the samba mailing list