NIS+ and smbpasswd

Kerry Jones kjones at
Wed Aug 4 23:23:53 GMT 1999


I saw a similar question to this one in the samba list archives, but
there was no answer so I'm going to ask it again.

I'm running Samba 2.0.5a on Solaris 2.6 using NIS+, I've compiled it
with --with-nisplus --with-nisplus-home. Samba is currently running
using Plain Text passwords accessing the NIS+ database and I have
"update encrypted = Yes" set so that the current SMB encrypted passwords
can be updated as people connect to file services over the next couple
of weeks.

I've used, and edited to change gcos
to full_name and home to home_dir, then populated the smbpasswd.org_dir
directory from passwd.org_dir using

The problem I now have is that when I run "smbpasswd username" to change
a users encrypted password I get the following error message.

tcsh> smbpasswd username
New SMB password:
Retype new SMB password:
make_smb_from_nisp: NIS+ lookup failure: Database for table does not
Failed to find entry for user username.
Failed to change password entry for username

The same error message shows up in log.smb when someone connects to a
file service and samba tries to update their SMB encrypted password. 

Can anyone please tell me why I'm getting this error message, and how
I'd go about fixing it?

If I compiled samba without the "--with-nisplus --with-nisplus-home"
would I still be able to use NIS+ for Plain Text/Unix encrypted
passwords and something like /etc/smbpassword for the SMB encrypted


Kerry Jones, Systems Manager
Australian Institute of Marine Science
kjones at

More information about the samba mailing list