encryption question

Dave Wreski dave at nic.com
Tue Sep 22 05:38:36 GMT 1998

Hi all.  There is something strange happening, and I can't figure out what.

I was using 1.9.17p4 (or so) on my solaris 2.6 box, serving files to a single
win95 machine on the same network.  I was not using password encryption on the
win95 workstation, and did not have encryption configured on the samba server.

I came into work this morning, and for some reason I couldn't login to the
samba server from the win95 machine, nor could I use smbclient and my normal
user ID.  It worked fine Friday, AFAIK.

I tried to enable the 'encrypted passwords = yes' option in the smb.conf, but it
said encryption wasn't enabled in the Makefile, so that didn't work.

So I downloaded and installed 1.9.18 on my Solaris machine.  It seems the
encryption is now compiled in by default in 1.9.18, as there was no Makefile
option to enable it, nor was there the 'encrypted passwords ...' option in the
sample smb.conf.

It now works just fine, but I'd really like to find out what happened, as I know
there were no changes between Fri and Mon...

Any ideas what possibly could have happened?


More information about the samba mailing list