It's just stopped working! (1.9.18p8, IRIX 5.3)

Mac dmccann at
Wed Oct 21 14:50:31 GMT 1998

>From: Mac <dmccann at>
>Subject: It's just stopped working! (1.9.18p8, IRIX 5.3)
>Date: 	Thu, 22 Oct 1998 00:15:14 +1000
>Hi all,
>I'm extremely puzzled by the behaviour of one of my Samba servers.  It's
>been working fine for yonks, and this morning (abuout 11:32) it just
>stopped. (mostly)
>Connecting to shares still works.  Navigating the tree till works.
>Changing (DOS) attributes still works.
>But actually opening files and reading the contents doesn't work.

I've solved it!

It turns out it _was_ and NFS problem, but at the NFS _server_ end.

The problem hinged around the 'lockd' which _was_ running, but was not
regiestered with portmapper (rpcbind).

I checked this with 'rpcinfo -p' (lists services registered with the
portmapper) on the (NFS) server, and noticed that 'lockmgr' was not a
registered service even though the daemon was still running.  This is
probably related to a restart of the portmapper this morning

A restart of the 'lockd' (rpc.lockd) solved the problem!

(proved by 'lockmgr' appearing in the 'rpcinfo -p' listing on the NFS

All files now readable.


          Assistant Systems Adminstrator
                        dmccann at
   Work: +44 1707 654753 x285      Everything else: +44 956 237670 (anytime)

More information about the samba mailing list