problem with the new rpm file

jdickins at jdickins at
Sat Jan 31 19:49:00 GMT 1998

hello all,

I just dl'd samba-1.9.18p2-42.8.i386.rpm for my system from the samba web
site. I got the one meant for rh 4.2 because that is what I have. I performed
the upgrade and my NT box (nt4 sp3) cannot login because the password is
wrong. Ok, I'll just run smbpasswd again and make sure it is the same as the
one on win nt. The problem is that I cant run smbpasswd, I get the error:
Permission Denied, even if I try and run the command as root (I used chmod to
make smbpasswd executable by normal users).

Ok, I thought that maybe this version was compiled with its smbpasswd file
option pointing somewhere else than where mine currently is:
/usr/local/samba/private/smbpasswd ... which is the default.

I also placed the following line in my smb.conf:
smb passwd file = /usr/local/samba/private/smbpasswd

I noticed in the new smb.conf that came with the rpm that the smb password
file might be located in /etc/smbpasswd so I ran the following command to
make a new smbpasswd file: cat /etc/passwd | >/etc/smbpasswd

I then changed the permissions on the new file, changed the line in smb.conf
to point to this new file, restarted smbd and nmbd, and tried to run
smbpasswd. I still got the same error. Argggg!!!

What I'm wondering is why cant I run smbpasswd and what were the default
compile options that were used with this rpm version?

As a side note, I already compiled this version of samba (1.9.18p2), but
never installed it because I wanted to use the rpm version for history
tracking. Anyways, if I run nmbd and smbd from the directory I compiled in,
everything works great. I can run the smbpasswd I compiled (probably because
I pointed out in the makefile where the smbpasswd file is located). I'd
rather not do a make install, but as of now, I dont know what else to do.

any suggestions are very appreciated


More information about the samba mailing list