NT Printing woes

Sean Murphy Sean.Murphy at Teltec.DCU.IE
Wed Jan 28 17:55:01 GMT 1998

Hi all,

I've had some problems printing from NT, which I thought I'd report 
to see if anybody can shed some light on them.

Server: 1.9.18p2, running on sparc ultra 1 compiled with gcc ver 

Clients: Win 95, Win NT (SP1 & SP3).

I had samba 1.9.17p5 installed. Everything worked fine. Then I 
installed version 1.9.18[then p1, and then p2], since the 
announcement said that it could lead to considerable speed 
improvements. This is where the problems arose.

I made no changes to my smb.conf when installing the new version. I 
just had a quick look at the docs which relate to printing, and found 
no mention of any new parameters that needed to be included in my 
smb.conf. I also ran the smb.conf through testparm and got a warning 
relating to the names of shares being too long, but I don't think 
this is the problem.

The server is operating in share mode. The hosts I'm printing from 
are allowed. Printing on each share is restricted to certain users, 
but the users that are having these printing problems are allowed 
(according to smb.conf) to print to the problematic shares.

After installing the new version of the server, the NT users couldn't 
print. I thought this might relate to the problem with printing from 
win 95, but this was fixed in 1.9.18p2. I did spend a bit of time 
attempting to figure out what the problem was, but not being very 
familiar with the workings of Samba, it took me quite a while to find 
out anything.

As far as I can see, the problem lies in the authentication 
procedure. Using level 3 debug output in the log files I came to this 

I monitored the behaviour of the server from the time the user logged 
onto the NT WS. The protocol was negotiated etc. When the network 
drives were connected, the server refused once and accepted the 
connection the next time. I think what happenned here is that NT 
tried to connect without password, samba refused, NT realised a 
password was needed, which it obtained from the user, sent it to 
samba, and samba authenticated the connection. This happenned for 
each mapped network drive. For the drive mappings, the 
authorise_login() function was called twice, once with no password, 
and once with the correct password.

When I tried to print a file using the new version, samba refused to 
authenticate the connection twice. In both cases, the 
authorise_login() function was called with nothing in the password 
field. Consequently, the connection was not authorised, and hence, 
the user could not print.

I've reverted to version 1.9.17p5, and the above problems 
disappeared, but I'd like to get 1.9.18 working.

Regards, and thanks in advance for any help,

Sean Murphy,		Phone: +353-1-7045080
Teltec Ireland,		Fax: +353-1-7045092
DCU, Dublin 9,		email: s.murphy at teltec.dcu.ie

More information about the samba mailing list