NTDOM snapshot problems and good news

Mike Black mblack at csihq.com
Mon Jan 5 11:00:13 GMT 1998

#1 - Got the snapshot smb-d2-28-dec.tgz for Linux.
#2 - Uncommented appropriate section (Linux - no shadow) in Makefile
#3 - make
checkos.sh: checkos.sh: No such file or directory
make: *** [CHECK] Error 1
#4 - Removed CHECK from Makefile to try and continue
Compiling util.c
Compiling system.c
Compiling charset.c
Compiling kanji.c
Compiling fault.c
Compiling smbencrypt.c
Compiling smbdes.c
Compiling charcnv.c
Compiling md4.c
Compiling loadparm.c
Compiling params.c
Compiling pcap.c
Compiling username.c
Compiling time.c
Compiling membuffer.c
make: *** No rule to make target `/usr/local/src/arcfour/arcfour.o', needed
by `smbd'.  Stop.
#5 - Removed path from 'makefile' for ARCFOUR_OBJ
#6 - Compiled OK now, but 'make install' gives:
installbin.sh: installbin.sh: No such file or directory
make: *** [installbin] Error 1
#7 - copied 'ins*' from alpha14 distribution
#8 - 'make install' worked (no docs of course) with one error:
Installing /usr/local/samba/bin/addtosmbpass
cp: addtosmbpass: No such file or directory
#9 - Restarted things and tried 'smbclient -L host' (note that I didn't
change smb.conf at all -- still using NT box as password server)-
Added interface ip= bcast= nmask=
Enter Password:
failed session setup
client_ipc_init: connection failed

        Sharename      Type      Comment
        ---------      ----      -------
cli_set_smb_cmd: buffers not allocated
Segmentation fault (core dumped)

Looks like I got password problems now...any suggestions?

Mike Black                            mblack at csihq.com
407-676-2923, x203                    FAX 407-676-2355
Computer Science Innovations, Inc.    http://www.csihq.com

More information about the samba mailing list