netbios-ssn/tcp: unknown service

Michael St. Laurent rowl at
Wed Feb 25 15:55:48 GMT 1998

The problem is likely to be that your argument list in inetd.conf is too
long.  There is a length limit that is easily exceeded.  See if you can get
by with just the -s to tell where your config file is located and do the
rest in the config file instead.
At 12:50 PM 2/25/98 +1100, joseph yang wrote:
>Sorry if this is such a basic question but I couldn't find anything about
this in the FAQs/HowTos/Digest.
>I've compiled samba-1.9.18p3 on SunOS4.1.3_U1.
>When I tried to run smbd via inetd.conf (SIGHUP), I always get the
following on the console.
>inetd[590]: netbios-ssn/tcp: unknown service
>I've edited the /etc/services to add:
>netbios-ssn     139/tcp 
>And the /etc/inetd/conf with the following line:
>netbios-ssn     stream  tcp     nowait  root    /usr/local/samba/bin/smbd
>-d1 -l/var/adm/smblogs/log -s/usr/local/samba/lib/smb.conf
>I also tried manually running the smbd at the prompt but nothing happens.
>What could be wrong? Is it my kernel doesn't support these services?  How
can I rectify this?
>Any help is appreciated. Thanx in advance.

Michael St. Laurent
Hartwell Corporation

"Whenever you find yourself on the side of the majority
it is time to pause and reflect."
               -- Mark Twain

More information about the samba mailing list